e. hello@alpha-tango.co.uk t. 01333 329882

Do you need to change your passwords for the HEARTBLEED bug

Published on 11th April 2014

Many of you might not have heard about the Heartbleed bug so I thought I repost this excellent article that is on Mashable.

Should you be worried and Heartbleed, YES!

You’re probably overdue a password change anyway so please do this ASAP.

Even if this list says they have patched the system, it could be the case the hackers already have your username and password, so a password change should be mandatory. Mashable have created a list of sites that use the technology that Heartbleed is targeted at so it’s important you change your passwords.  Go to http://mashable.com/2014/04/09/heartbleed-bug-websites-affected to see the list.

I appreciate the majority of people will do nothing, it’s human nature as we can’t feel the threat, but at least change the passwords that are most important, Google, Social sites, Yahoo mail, and more.

If you want to understand what this bug actually is then play the video from Techcrunch below, it is a little geeky…

OpenSSL Heartbeat (Heartbleed) Vulnerability (CVE-2014-0160) and its High-Level Mechanics from Elastica Inc on Vimeo.

0/5 (0 Reviews)

Categories: Security

  • Subscribe

    • This field is for validation purposes and should be left unchanged.
  • Categories

  • Get In Touch

    Alpha Tango
    44 Toll Court
    Lundin Links
    Fife, KY8 6HH

    o: 01333 329882
    Skype: alantomkins
    hello@alpha-tango.co.uk


    Call Me Back

    • This field is for validation purposes and should be left unchanged.
    Alpha Tango